Get in touch
Back
Resolved

Some users cannot be added as auditors

Started 5 Nov at 08:18am PST.

Web App
Created

The issue in which customers were unable to add an auditor has been resolved. Our engineering team will continue to monitor closely.

Posted 5 Nov at 08:18am PST.