Get in touch
Back
Degraded

Some customers experiencing ownership discrepancies

Started 22 Oct at 09:31am PDT, resolved 30 Oct at 05:04pm PDT.

Web App
Resolved

Ownership data for all affected customers has been restored.

Posted 30 Oct at 05:04pm PDT.
Updated

Ownership has been restored for the additional customers impacted. Our team is monitoring to ensure all affected data has been restored

Posted 30 Oct at 12:18am PDT.
Updated

The team has identified some additional customers impacted by the incident and is working to restore the ownership of their records.

Posted 29 Oct at 09:41pm PDT.
Updated

Risk owners and risk reviewers have been restored.

Posted 29 Oct at 07:24pm PDT.
Updated

Risk assessment ownership has been restored. Our team is continuing to work towards restoration of risk owners and risk reviewers.

Posted 28 Oct at 02:40pm PDT.
Updated

Vendor ownership has been restored. Our team is continuing to work on restoring risk ownership.

Posted 28 Oct at 11:05am PDT.
Updated

Evidence ownership has been restored. Our team is continuing to work toward restoration of ownership of risks and vendors.

Posted 27 Oct at 11:45pm PDT.
Updated

Policy ownership has been restored. Our team is continuing to work toward restoration of ownership of risks, vendors, and evidence.

Posted 27 Oct at 11:11pm PDT.
Updated

Control ownership has been restored. Our team is continuing to work toward restoration of ownership of risks, vendors, policies, and evidence.

Posted 27 Oct at 06:45pm PDT.
Updated

The team is making progress on restoration of ownership within each account. We will provide more updates as they become available.

Posted 27 Oct at 04:11pm PDT.
Updated

The team continues to work toward full restoration of all ownership. We will provide updates as they become available.

Posted 27 Oct at 07:16am PDT.
Updated

Discrepancies with asset and framework ownership have been restored. We expect to have control and risk ownership restored soon, and continue to work towards restoration of ownership for vendors, policies, and evidence.

Posted 25 Oct at 01:59pm PDT.
Updated

Our team is continuing to work towards restoring ownership for assets, controls, frameworks, policies, risks, and vendors. Control and framework readiness are not affected.

Posted 24 Oct at 12:13pm PDT.
Updated

All user logins, roles, and permissions have been restored. Our team is continuing to work towards restoring ownership for assets, controls, frameworks, policies, risks, and vendors. Control and framework readiness are not affected.

Posted 23 Oct at 11:21am PDT.
Updated

The restoration of login and expected role access is in progress.

Posted 22 Oct at 09:46pm PDT.
Updated

Our team has identified the issue preventing some users from logging in. We are working to restore access and will provide more updates as they become available.

Posted 22 Oct at 01:03pm PDT.
Created

Our team is currently investigating an issue in which some users are unable to login. We will provide updates as they become available.

Posted 22 Oct at 09:31am PDT.