Get in touch
Back
Degraded

Evidence Library hangs when evidence is past the renewal date

Started 2 May at 11:12am PDT, resolved 2 May at 03:35pm PDT.

Web App
Resolved

The incident is resolved

Posted 2 May at 03:35pm PDT.
Created

We have identified an issue in which the Evidence Library drawers hang when evidence is past the renewal date. We are actively working on a fix.

Posted 2 May at 11:12am PDT.