Get in touch
Back
Degraded

Email delivery delays

Started 8 Apr at 12:22pm PDT, resolved 8 Apr at 02:51pm PDT.

API US Agent API US API EU Agent API EU
Resolved

Email delivery is now fully restored and working as expected.

Posted 8 Apr at 02:51pm PDT.
Updated

Emails are now being delivered in near-real time as expected. We will continue to monitor for further issues for a short while before fully resolving the incident.

Posted 8 Apr at 01:50pm PDT.
Created

Some customers are expecting delays in email delivery. We have detected the root cause and expect delivery completion within the next hour.

Posted 8 Apr at 12:22pm PDT.