Get in touch
Back
Degraded

Trust Center public pages are failing to load for EU customers without CNAMEs.

Started 20 Feb at 01:23pm PST, resolved 20 Feb at 07:55pm PST.

Web App
Resolved

A fix for the issue in which public Trust Center Essential pages were failing to load for EU hosted customers has been deployed. This incident is resolved.

Posted 20 Feb at 07:55pm PST.
Created

EU customers are experiencing errors loading their Trust Center public pages without a CNAME. We are actively working on a fix.

Posted 20 Feb at 01:23pm PST.