Get in touch
Back
Degraded

AuditHub Evidence Issue

Started 6 Feb at 05:26pm PST, resolved 7 Feb at 12:53pm PST.

Public API US Public API EU
Resolved

The prior issue auditors were experiencing with evidence downloads has been resolved.

Posted 7 Feb at 12:53pm PST.
Created

Our team is currently investigating an issue in which auditors are not receiving expected evidence link upon download. We will provide updates as available.

Posted 6 Feb at 05:26pm PST.