Get in touch
Back
Degraded

Some Trust Center email downloads might be failing

Started 7 Dec at 05:48pm PST, resolved 7 Dec at 08:12pm PST.

Web App
Resolved

The fix has been implemented and verified. The incident is closed.

Posted 7 Dec at 08:12pm PST.
Updated

The root cause has been identified. We are actively working on a fix.

Posted 7 Dec at 06:53pm PST.
Created

Some customers might experience Trust Center email downloads failing. We are currently investigating this issue.

Posted 7 Dec at 05:48pm PST.