Get in touch
Back
Maintenance

Drata Maintenance

Completed 24 Sep at 12:00pm PDT.

Web App API US
Completed

Maintenance completed

Posted 24 Sep at 12:00pm PDT.
Started

On Saturday, September 24th from 9:00am-12:00pm PT (12:00pm-3:00pm ET) all Drata tenants will be included in a scheduled maintenance window. Drata will be temporarily unavailable.

This time will be used to further enhance users experience on Drata and ensure the highest level of security is maintained.

We thank you for your patience in advance.

Posted 24 Sep at 09:00am PDT.